Sentinel est une extension vous permettant de prévenir des attaques en vérifiant les différentes requêtes HTTP sur un ensemble de règles. Elle filtre alors les requêtes et détermine si elle est malveillante ou non. Un message personnalisée peut alors être affiché. Dans les options de l’extension, trois onglets sont disponibles et permettent de configurer les informations à afficher lors d’une détection d’attaque. Le premier onglet « Journal de bord » affiche le récapitulatif des attaques. Ceci comprend l’élément d’attaque et la valeur souhaitée.

Sentinel dispose également d’outils avancés de notifications. Lors d’une attaque, l’administrateur du blog peut alors être notifié par courrier électronique des éléments et la procédure d’utilisation de l’attaque en cours d’exécution. Si vous le souhaitez, vous pouvez télécharger le journal de bord. Dans l’onglet « Paramètres« , plusieurs options sont affichées, telle que le délais avant d’être considéré comme un envoie massif de données inutiles (flood). Une liste blanche est également présente pour exclure certaines requêtes. Notons qu’il est possible de personnaliser le courrier électronique envoyé à l’administrateur depuis l’onglet « Apparence« .

Cette extension est capable de bloquer ces types d’attaques :

  • Cross Site Scriptings
  • HTML Injections
  • Remote File Inclusions
  • Local File Inclusions
  • SQL Injections
  • Cross Site Request Forgery
  • Login bruteforcing
  • Flooding

Intégrer un système de sécurité à votre installation WordPress !

BRANDT Valentin

Créateur de Geekeries.fr. Référentiel de ressources WordPress en Français qui a vu le jour pour la toute première fois en 2007. Je publie régulièrement des plugins, des outils SEO, des ressources et de l'actualités pour améliorer votre expérience avec le CMS WordPress.

Ne manquez pas nos autres contenus :