Améliorer l’éditeur TinyMCE de WordPress


TinyMCE Advanced est une extension vous permettant d’améliorer l’éditeur visuel TinyMCE utilisé par défaut sur WordPress. Après son activation, de nouvelles icônes sont d’ores et déjà disponibles dans votre éditeur visuel. Dans les options de l’extension, il vous est possible de gérer l’emplacement des nouvelles options et icônes via un simple glisser/déposer. Une trentaine de nouvelles options sont disponibles, à répartir sur quatre lignes d’options. Bien que cette extension est destinée à un usage avancé, pour les développeurs par exemple, n’utilisez que les options dont vous avez besoin.

TinyMCE Advanced dispose également d’options avancées. Vous les trouverez en bas de la page d’options.

  • Désactiver l’internal Linking
  • En effet, il est possible de remplacer la nouvelle fonctionnalité de WordPress 3.1 ! Dorénavant, lors de l’ajout d’un lien, plusieurs onglets et options avancées sont disponibles. Un excellent moyen de gérer les liens que vous faites.

  • Importation de la feuille de style
  • Suppressions des IFRAMES
  • Gestion des tags HTML 5
  • Supprimer les styles « menus » de l’éditeur
  • Désactiver la suppression des paragraphes et sauts à la ligne

Allez plus loins

7 réponses

  1. C’est une excellent initiative. Sur un de mes blogs, je n’ai tout simplement plus l’éditeur TinyMCE et j’ai beau cherché la cause et toujours pas trouvé. pensez-vous que je devrais installer cet extention pour résoudre le problème ?

  2. Merci pour votre réponse rapide. Je vais envisager cette solution. Je suis toujours bluffé par les mises en place sur ce blog. Par exemple pour les sondages. J’aurais besoin de faire la même chose sur ma page de sondages.

  3. Avec l’expérience, j’ai fini par préférer désactiver l’éditeur visuel qui est susceptible de modifier malencontreusement le code des pages et articles, et j’ai installé le plugin Text Control afin de désactiver le formatage du contenu et de produire un code propre.

  4. Bonsoir, merci pour ces informations.
    Je suis en train de lutter avec ce foutu filtre inventé par WordPress (je ne sais pas pourquoi) wp-autop, je n’édites mes pages que grace à l’éditeur html, mais si je repasses sur tinymce et ensuite bascule sur l’editeur html, la patatrac, des balises p à m’en plus finir, si quelqu’un a enfin la solution

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *