WordPress 3.2 : plus rapide, plus léger !

Suite à l’annonce officielle sur le blog américain de WordPress, nous savons maintenant ce qu’ils nous réservent dans les prochaines années. En effet, l’annonce est radicale concernant les prochaines évolutions de WordPress Lire l’annonce officielle en anglais !

Dans un avenir proche, l’évolution et l’approche de WordPress vont changer. La politique depuis le début était de rendre accessible à n’importe qui d’héberger une installation WordPress et ainsi créer du contenu riche en toute simplicité. Cependant, cette politique va être modifié pour les prochaines grandes évolutions. Les conditions requises lors d’une installation ont été réévaluées et il sera maintenant obligatoire, pour toutes personnes voulant profiter de la puissance du gestionnaire de contenu, d’un hébergement puissant, utilisant les nouvelles versions de MySQL (5) et PHP (5.2). Cette nouvelle stratégie prendra effet lors du développement et du lancement de WordPress 3.2.

Logo WordPress

Toutefois, l’équipe de développement nous précises que cette version sera disponible dans le courant de l’année 2011 et que le support de PHP 4 et MySQL 4 seront donc complètement abandonnes après la version de WordPress 3.1. Cette prochaine mise à jour sera donc la dernière supportant ces formats populaires, mais permettrons à certains de profiter encore, s’il le souhaite d’une installation complète et riche en fonctionnalités. Les autres gestionnaires de contenus, tel que Drupal et Joomla utiliseront aussi cette politique de mise à niveau des technologies dans leurs prochaines versions publiques.

Votre installation est-elle compatible ?

Bien sûr, vous vous êtes assuré d’avoir un hébergement compatible WordPress tel que EasyHoster.com

Health Check est une extension, développée pour l’occasion, vous indiquant si l’espace de votre installation WordPress (serveur et configuration) seront compatibles avec les prochaines évolutions. Une fois activé, un message vous sera affiché (après diagnostics avancé de votre installation), pour vous informer de la compatibilité ou l’incompatibilité de votre infrastructure d’hébergement.

« Excellent: Votre serveur exécute la version PHP 5.2.13 et la version MySQL 5.0.81 qui sont idéales pour WordPress 3.2 »

En résumé

La prochaine mise à jour important, WordPress 3.1 sera normalement disponible fin 2010 et sera la dernière version de WordPress utilisant les versions PHP 4 et MySQL 4. WordPress 3.2, sera disponible dans le courant de l’année 2011 et nécessitera obligatoirement sur votre infrastructure d’hébergement PHP 5.2 ou supérieur et MySQL 5.0.15 ou supérieur. Une extension est également disponible vous permettant, en un coup d’oeil, d’observer si votre infrastructure est compatible avec les prochaines évolutions du système de gestion de contenus.

Plus rapide, plus léger

Nous en savons un peu plus, ce vendredi 18 mars suite au communiqué de Jaquith Mark. L’échéancier sera disponible la semaine prochaine, mais voici un aperçu du plan prévu pour la prochain amélioration majeure, WordPress 3.2.

  • Un cycle de sortie plus rapide
  • Fin du support d’Internet Explorer 6
  • Accélération des thèmes ainsi qu’une meilleure optimisation.
  • Utilisation des technologies PHP 5.2.4 et MySQL 5
  • Possible amélioration de l’éditeur. (source d’inspiration)
  • De meilleurs mises à jours automatiques.
  • Amélioration de l’administration via PHP lazy loading et des traités via FTP

Allez plus loins

24 réponses

  1. Parfait, mon serveur passe sans soucis :P

    Avec ça, je pense que les hébergeurs mutualisés devront upgrader leur version de php & mysql pour tenir la route, c’est un bon point au final !

        1. En general ils sont un peu lent a migrer car ils doivent composer avec des besoins très différents et des utilisateurs qui spam les newsgroup en masse dès qu’un truc ne fonctionne pas. De plus comme ils n’assurent aucun sla ni garantie que tes données ne seront pas effacé pour une raison X ou Y ils ont pas trop envie de faire bouger les config. Apres il est toujours possible d’aller demander dans les newsgroup de migrer vers un serveur qui serait en train de tester une config plus recente :)

  2. @iDorian C’est corrigé :) merci.

    @Crunch, @Diti En effet, c’est une bonne nouvelle, mais ceux qui ne veulent pas ou ne peuvent pas migrer vers une bonen installation seront embêtés..

  3. Notons qu’il est possible d’activer PHP 5 sur Free, grâce au fichier « .htaccess » en y ajoutant la ligne suivante : php 1. Ce n’est qu’un détail.

  4. Sinon, pour ceux qui n’ont que peu de moyen mais qui souhaitent passer sur un hébergement payant, les offres mutualisées d’OVH sont plus qu’intéressantes (j’utilise l’offre à 1,99 €/mois) et les versions de MySQL et PHP sont à jours ;)

    1. Sur le forum d’aide de WordPress-fr.net, j’ai vu des gens se plaindre qu’ils ne recevaient plus les notifications de mises à jour avec un hébergement OVH (il y a 1 an). C’est toujours d’actualité ?

      1. vous parlez des notifications de mises à jour de plugins,de WordPress ?
        J’ai un site chez OVH et je n’ai jamais eu ce problème, les gens étaient-ils bien sous php5 ?
        Par rapport à Guillaume,je déconseille OVH, serveur instable ,formule chère surtout à l’époque où j’ai pris un hébergement chez eux,depuis plus d’ 1 an j’ai pris pour une association un hébergement chez 1&1 et j’en suis ravi,serveur stable,prix correct,offre intéressant.

        1. Je suis sur 1&1, le souci c’est que la mémoire php est limitée à 32Mo, et avec l’augmentation des ressources de WordPress (et des plugins) du coup je ne peux plus pondre d’articles fleuve sous peine de ne pas pouvoir les sauvegarder parce que j’ai dépassé la limite de mémoire.

    1. Tu n’as pas besoin de contacter OVH pour ça. C’est à toi de faire une manip : modifie ou crée ton fichier .htaccess à la racine de ton répertoire et ajoute à la ligne : « SetEnv PHP_VER 5 ».

      Pour plus d’info : http://guides.ovh.com/ConfigPhp

      Il faut savoir que tu peux aussi activer PHP6

  5. Pour moi c’est une très bonne nouvelle. Il y a trop de CMS qui utilise PHP 4 pour être compatibles, mais du coup on passe à coté de pas mal d’optimisations. Faut un peu avancer, on passera bientôt à PHP 6, on peut quand même abandonné PHP 4 ! Une fois que toutes les bonnes habitudes seront prises pour le développement de plugins, l’utilisation systématique de la POO, ça ira beaucoup mieux ;)

  6. @Dric, je suis chez Easy-Hébergement depuis plus d’un an et je n’ai jamais eu un soucis avec eux. Même dans leur offre d’hébergement par micropaiement tu as la possibilité de modifier ton php.ini et donc de passer l’option memory_limit à 64 Mo.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *