😊Hello, -10% sur le Thème WordPress DIVI d'ElegantThemes.com 🔥

Activer PHP5 sur vos installations WordPress !

Actuellement, le bon fonctionnement de votre installation WordPress réside essentiellement dans l’utilisation de la version 5 de PHP. En effet, cela est la cause, pour la plupart du temps, des erreurs rencontrées lors de l’activation de certaines extensions.

Nous vous proposons de découvrir comment activer la version PHP5 de votre serveur. Les hébergeurs, gratuits ou payants, n’ont généralement pas activé cette version, mais il est possible via un fichier de configuration web Apache (.htaccess) d’activer cette version et ainsi profiter pleinement des fonctionnalités des extensions WordPress ou tout simple d’autres scripts externes. Ce petit rappel est éventuellement essentiel pour la suite des événements et des démarches liées au gestionnaire de contenu WordPress, qui dans version 3.2, nécessitera obligatoirement PHP 5. Cette liste, si vous souhaitez nous aider via les commentaires, peut être évolutive.

Votre hébergeur et fichier .htaccess

Pour connaitre la version PHP de votre installation ou pour avoir confirmation de la modification apportée par l’ajout des lignes adéquates dans votre fichier « .htaccess » nous vous conseillons simplement d’installer l’extension « PHP Info » qui vous permet de visualiser la configuration de votre serveur. L’information qui nous interesse est en bas de la deuxième boite de dialogues (PHP Version). Vous pouvez également visualiser votre version en créant un fichier php (à supprimer par la suite) contenant la ligne suivante.

<?php phpinfo(); ?>

1&1 :
Si vous êtes hébergé chez eux, il vous suffit de créer/modifier un/le fichier se nommant « .htaccess » à la racine de votre installation WordPress, ou de l’ensemble de votre espace web. Par la suite, insérez la ligne suivante pour activer la modification.

AddType x-mapp-php5 .php

Cet hébergeur dispose d’un autre code pour activer cette fonctionnalité importante. Il n’est pas nécessaire de fournir les deux codes présentés.

AddHandler x-mapp-php5 .php

OVH :
Si vous êtes hébergé chez eux, il vous suffit de créer/modifier un/le fichier se nommant « .htaccess » à la racine de votre installation WordPress, ou de l’ensemble de votre espace web. Par la suite, insérez la ligne suivante pour activer PHP 5.

SetEnv PHP_VER 5

Avec cet hébergeur vous pouvez également utiliser la version test de PHP 5.3, pour cela coller la ligne suivante dans votre fichier « .htaccess« .

SetEnv PHP_VER 5_TEST

Free :
Si vous êtes hébergé chez eux, il vous suffit de créer/modifier un/le fichier se nommant « .htaccess » à la racine de votre installation WordPress, ou de l’ensemble de votre espace web. Par la suite, insérez la ligne suivante pour activer les modifications.

php 1

AquaRay :
Si vous êtes hébergé chez eux, il vous suffit de créer/modifier un/le fichier se nommant « .htaccess » à la racine de votre installation WordPress, ou de l’ensemble de votre espace web. Par la suite, insérez la ligne suivante pour activer les modifications.

AddHandler php5 .php

Infomaniak :
Si vous êtes hébergé chez eux, il vous suffit tout simplement de vous rendre dans votre espace client et d’activer la fonctionnalité, si cela n’est pas déjà fait.

Amen :
Si vous êtes hébergé chez eux, il vous suffit tout simplement de vous rendre dans votre espace client, onglet « Langages Supportés » du module « Hébergement » et d’activer la fonctionnalité, si cela n’est pas déjà fait !

EasyHoster :
Si vous êtes hébergé chez eux, il vous suffit tout simplement de sélectionner la version qu’il vous faut dans cPanel : PHP 4.4, PHP 5.6, PHP 7 (pour cette version assurez-vous de la compatibilité de vos scripts).

Partager sur facebook
Facebook
Partager sur whatsapp
WhatsApp
Partager sur linkedin
LinkedIn
Partager sur twitter
Twitter

Allez plus loins

7 réponses

  1. Et pour Alwaysdata, il suffit de se rendre dans son interface client, et de changer l’option. A noter, au même endroit, on peut modifier le contenu du PHP.ini, c’est assez rare de pouvoir le faire sur un hébergement mutualisé, autant le préciser!

  2. bonjour, ma PHP Version est 5.1.6 et il me faudrait passer en 5.2.4 au minimum pour mettre à jour ma version de WP, seulement je ne sais pas comment faire… d’autant que mon serveur est mutualisé avec d’autres blogs que je ne voudrais pas impacter par ma modification… Par avance merci pour votre aide !

  3. chez 1&1,il suffit d’aller dans l’espace client,1er cadre en haut à gauche,trouver l a ligne « Version globale de PHP » et choisir PHP5,c’est tout

  4. Cet article n’est pas récent (date de deux ans) mais il m’a réellement aidé, j’ai mis une bonne heure à activer php5 sur mon serveur. Merci beaucoup, j’avais déjà regardé d’autres articles de geekeries.fr et ceux sont tous de vrais mines d’informations !!

  5. Bonjour
    Je suis chez OVH
    Ils ont les versions 5.4, 5.5 et 5.6 ainsi que la 7.0

    J’ai activé la 5.6 pour tous mes sites mais j’ai besoin de la 5.4 pour un site ancien…

    Que dois-je mettre dans mon .htaccess pour forcer la 5.4 pour ce site ?

    SetEnv PHP_VER 5 ne permet pas de préciser quelle version de la 5 ?…

    D’avance merci

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

👋 Hello,

Bienvenue sur BlogInfos.com !

Vous allez bientôt être redirigé vers notre partenaire ElegantThemes.com

Si vous ne souhaitez pas être redirigé vers notre partenaire et accéder à l’article, cliquez sur Fermer Maintenant.

FERMER MAINTENANT

DIVI - THÈME WORDPRESS

-10%

👋 Le site ElegantThemes.com propose une réduction de 10% et elle ne sera disponible que pendant quelques temps. Ne manquez pas ça !

En cliquant sur le lien « Fermer Maintenant » vous acceptez d’aider ce site et d’être redirigé vers notre partenaire ElegantThemes.